Build Your Own Clone Message Board

It is currently Sun Jul 21, 2019 1:09 pm

All times are UTC - 6 hours




Post new topic  [ 1747 topics ]  Go to page 1, 2, 3, 4, 5 ... 70  Next
 Topics   Author   Replies   Views   Last post 
Announcements
No unread posts Defective Jacks in LEEDS FUZZ KITS/ No bypass

byoc

0

3954

Thu Jul 14, 2011 11:28 am

byoc View the latest post

No unread posts REPLACEMENT TRANSISTOR SETS

byoc

1

6221

Sun Oct 19, 2014 1:33 pm

JaySon2014 View the latest post

No unread posts Attachment(s) SUMMER TIME HEAT AND GERMANIUM TRANSISTORS

byoc

19

13218

Fri Jul 15, 2016 9:53 am

Roe View the latest post

Topics
No unread posts Attachment(s) Fuzz PCB Layouts

Stephen

0

4608

Wed Aug 08, 2012 6:24 pm

Stephen View the latest post

This topic is locked, you cannot edit posts or make further replies. Before your first build....READ THIS!!

duhvoodooman

0

6379

Thu Dec 08, 2011 9:27 pm

duhvoodooman View the latest post

No unread posts Large Beaver 2.0 Troubleshooting

duhvoodooman

2

6430

Sat Dec 03, 2011 2:09 pm

Stephen View the latest post

No unread posts Sound clips can go here

Brownie

8

8109

Mon Oct 31, 2011 12:13 pm

mmarsh View the latest post

No unread posts Attachment(s) Prepping & wiring the 3PDT footswitch

duhvoodooman

2

4797

Wed Oct 26, 2011 12:52 pm

duhvoodooman View the latest post

No unread posts Some useful Big Muff-related websites

duhvoodooman

0

4741

Fri Mar 05, 2010 11:00 am

duhvoodooman View the latest post

No unread posts Large Beaver 2.0 Color-coded PCB & Schematic + other info

duhvoodooman

2

6931

Thu Aug 13, 2009 1:36 pm

duhvoodooman View the latest post

No unread posts IMPORTANT: Before you post asking for help please read this

baj2k

2

8671

Fri Apr 17, 2009 3:51 am

Naz Nomad View the latest post

This topic is locked, you cannot edit posts or make further replies. Required reading for Fuzz Freaks... well, sort of... :)

baj2k

0

6334

Mon Aug 06, 2007 9:09 pm

baj2k View the latest post

No unread posts Attachment(s) Classic Fuzz,LED and bypass work no sound

shaebishhh

10

141

Sun Jul 21, 2019 12:54 pm

duhvoodooman View the latest post

No unread posts Attachment(s) Octave Fuzz - bypass ok, NO led and NO sound when engaged

Tom

9

183

Tue Jul 16, 2019 8:33 pm

duhvoodooman View the latest post

No unread posts Mistake in Silver Pony Instructions

rhodco

3

71

Wed Jul 03, 2019 7:04 pm

duhvoodooman View the latest post

No unread posts Bender transistor leakage

Big O

0

89

Mon Jun 24, 2019 3:24 pm

Big O View the latest post

No unread posts Octave Fuzz - Bypass = Fine, Active = no led, no sound, etc

smoke

6

274

Fri Jun 21, 2019 12:03 pm

duhvoodooman View the latest post

No unread posts Large Beaver build general question

joelorigo

15

655

Mon Jun 17, 2019 6:12 pm

joelorigo View the latest post

No unread posts Color Booster favorite settings...

duhvoodooman

0

108

Tue Jun 11, 2019 10:10 am

duhvoodooman View the latest post

No unread posts Classic Fuzz — volume issues or working as intended?

Dmg

2

158

Mon Jun 03, 2019 6:03 pm

Dmg View the latest post

No unread posts Octafuzz transistor question (SOLVED)

Tom

4

211

Sat Jun 01, 2019 8:25 am

Tom View the latest post

No unread posts Attachment(s) New Guy

iansmantra

2

192

Sat Jun 01, 2019 8:13 am

Stephen View the latest post

No unread posts Large Beaver (Russian) troubleshooting

Kypes

6

283

Thu May 23, 2019 6:52 pm

jimilee View the latest post

No unread posts Large Beaver Triangle potentiometer cover?

Ribspare

1

186

Fri Apr 05, 2019 10:37 am

Nwkenning View the latest post

No unread posts Leeds Fuzz issue. No power

trevorcarr

9

454

Wed Mar 27, 2019 11:47 am

trevorcarr View the latest post

No unread posts Attachment(s) High frequency noise with li'l beaver ram's head (solved)

yoshiki

5

513

Mon Mar 18, 2019 12:06 pm

yoshiki View the latest post

No unread posts Attachment(s) Octave Fuzz Pedal only work in true bypass.

rampagerye

3

257

Fri Mar 15, 2019 9:51 am

rampagerye View the latest post

No unread posts ESV Silicon Fuzz - Powers on but no sound - SOLVED

Clintird13

4

269

Thu Mar 14, 2019 10:19 am

duhvoodooman View the latest post

Display topics from previous:  Sort by  
Post new topic  [ 1747 topics ]  Go to page 1, 2, 3, 4, 5 ... 70  Next

All times are UTC - 6 hours


Who is online

Users browsing this forum: duhvoodooman and 2 guests


Unread posts Unread posts    No unread posts No unread posts    Announce Announcement
Unread posts [ Popular ] Unread posts [ Popular ]    No unread posts [ Popular ] No unread posts [ Popular ]    Sticky Sticky
Unread posts [ Locked ] Unread posts [ Locked ]    No unread posts [ Locked ] No unread posts [ Locked ]    Moved topic Moved topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group